Ospd-openvas int() argument must be a string

I recently reinstalled ospd-openvas. Everything had been working properly, but after reinstallation when I run ospd-openvas I get the folllowing error:

" load_entry_point(‘ospd-openvas==20.4a1’, ‘console_scripts’, ‘ospd-openvas’)()#012 File “/lib/python3.7/dist-packages/ospd_openvas/daemon.py”, line 1454, in main#012 daemon_main(‘OSPD - openvas’, OSPDopenvas)#012 File “/lib/python3.7/dist-packages/ospd/main.py”, line 159, in main#012 daemon.init()#012 File “/lib/python3.7/dist-packages/ospd_openvas/daemon.py”, line 293, in init#012 self.load_vts()#012 File “/lib/python3.7/dist-packages/ospd_openvas/daemon.py”, line 410, in load_vts#012 _vt_params = self.nvti.get_nvt_params(vt_id)#012 File “/lib/python3.7/dist-packages/ospd_openvas/nvticache.py”, line 82, in get_nvt_params#012 if int(timeout) > 0:#012TypeError: int() argument must be a string, a bytes-like object or a number, not ‘NoneType’"

It’s from the master branch, but reversing to 2.0.0 gives the same error.

Anyone encountered a similar error before? I have no idea as of now what causes it.

You should check your timeout setting. It seems it isn’t defined and therefore ospd crashes. Of course this should not happen.

Btw. please don’t use versions from master if you are not familiar with fixing bugs by yourself. Master branches always may contain partly finished features and therefore may be broken in some kind.