Openvasmd fails to communicate with openvassd

Hi everyone !

I had a linux server running openvas actively for quite some time now and everything was working fine until now. My configuration is as follow:

Linux mint 18.3 Sylvia 64bits
Openvas 8 (scanner 5.0.7, manager 6.0.9)
Redis 2:3.0.6-1

Last week I was running a scanning campaign against several networks and everything went well until two days ago where I noticed my scans were stucked at various percentages, without progressing anymore.

Looking at both openvasmd and openvassd logsfiles gave me the following last messages:

md main:WARNING:2018-11-11 11h10.42 CET:6270: NVT ‘’ not found. Result not created.
md main:WARNING:2018-11-11 11h10.46 CET:6270: NVT ‘’ not found. Result not created.

[Sun Nov 11 09:59:54 2018][20850] WARNING: Cannot connect to KB at ‘/var/run/redis/redis.sock’: Connection refused’
[Sun Nov 11 09:59:55 2018][6454] WARNING: Cannot connect to KB at ‘/var/run/redis/redis.sock’: Connection refused’

So I restarted redis, openvas scanner and openvas manager and then I cannot resume my tasks anymore. If I try to run a task via omp, it gets stuck forever…

I know that in the past similar problems were often due to a configuration issue with redis, so I checked that and my redis settings are correct. It’s socket-listening and my redis save settings are:

save 900 1
save 300 10
save 60 10000

So really everything looks fine. I tried to rebuild openvasmd database with --rebuild parameter, but here also openvasmd gets stuck forever.

So really, openvasmd seems unable to talk to openvassd processes anymore.

I would appreciate if any of you guys would have any clue on this, as I’m currently stucked into a quite important campaign for my network !

Thanks again

This is again likely a redis issue. Please take a look at

for further advises. Also please be aware that OpenVAS 8 is end-of-life. It doesn’t get any updates nor fixes anymore. Please upgrade to GVM 9



as pointed out by the article linked by @bricks those needs to be commented out like e.g.:

# save 900 1
# save 300 10
# save 60 10000

followed by a flush of redis, deletion of the dump file and a restart of redis.

Furthermore OpenVAS 8 might be affected by Community feed unusable as well. So it is really strongly suggested to migrate to the latest GVM-9 releases as pointed out by @bricks.

1 Like

Thanks guys, fixing redis configuration did the trick. My apologizes for this :roll_eyes:, for whatever reason I actually thought that those settings had to be commented out to avoid the redis problem, not the other way. I’m getting old, my memory is leaking… :stuck_out_tongue:

Thanks again for your quick help on this !

1 Like

Yes, I know openvas 8 is EOL. Problem is I can’t upgrade by now as I have written many scripts for reports generations which worked with omp but doesn’t with gvm. So I need to fix those first. But it’s definitely in my todo list.

Thanks agin !