Openvas unable to sync NVTs

After compiling and installing openvas from source I run greenbone-nvt-sync and get these messages:


tar: xtel_detect.nasl: Cannot open: Permission denied
tar: xtelw_detect.nasl: Cannot open: Permission denied
tar: yahoo_msg_running.nasl: Cannot open: Permission denied

But when I run w/ sudo, I get this message:

/usr/local/bin/greenbone-nvt-sync must not be executed as privileged user root

Unlike the actual scanner the sync routine does not need privileges.
Accidental execution as root would prevent later overwriting of
files with a non-privileged user.

How do I sync NVTs?

Hi @Greenmax,
I guess you have installed openvas with “sudo make install” or you had and old version. Therefore the plugin folder was created with rw permission only for the root user.
You have to give permission to your user (or the user which you run greenbone-nvt-sync with) to read/write in the plugin folder.

1 Like

One important additional note to the following:

This check has been added to the “master” branch only (in which means you’re currently trying to use a development version of GVM.

Please note that the “master” branch is where all development is happening. This branch might show unexpected behavior or could even break at any time.

If you don’t want to contribute to the development of GVM and want to have the best experience with GVM it is strongly suggested to stay with the official announced source code releases in About the Greenbone Source Edition (GSE) category.

1 Like