OpenVAS givind no results(severity N/A)

hi. i have tried each and every possible solution for getting a rsult after a scan but severity is still N/A. i have visited each and every link on this forum for solution but my problem is still not solved kindly guide me. and plz dont ask mme to follow a previous conversation as i have read and tried them all.

1 Like

Could you describe your problem in more detail, please? On which appliance are you running which version of GOS or how else did you deploy GVM? Did you build from source, are you using a package from, e.g. Kali Linux (which is not supported by us, by the way), or are you using the community edition?

Before we don’t have those information we can not even begin to track down what’s wrong. Give as much helpful information as possible, please.

Also, this question does not seem to be related to the “Vulnerability Tests” category. Maybe you can categorize your problem correctly and it will be lot easier to see what’s wrong.


Hello sir, i am using kali linux (version 2020.2).
The problem is,when ever i scan any target i get no scan results.The results have severity as N/A and when i use consider alive option the result is 0.0(log)

1 Like

Most likely you don’t have any NVTs for the scan. Please check the webpage SecInfo -> NVTs if it lists any NVTs. Otherwise you need to run greenbone-nvt-sync.

1 Like

Please note that Kali is shipping an outdated and end-of-life version of GVM (GVM-9 lacking two Major versions behind) which might contains bugs / issues causing the seen problem.

Until Kali is catching up to provide the recent GVM-11 version i would suggest to:

  1. Build the recent GVM 11 (stable, initial release 2019-10-14) from source
  2. Use the ready to use GCE from Setting up the Greenbone Community Edition (GCE) Virtual Machine
1 Like

i have already checked NVTs . they are present in list format

Please upgrade to a supported version. As cfi told you, that version if end of life and the support for it already ended. You can try to get support from the Kali community but here is nothing we can do.

1 Like

In that case please check you redis server setup. There are a lot of topics in this forum for fixing and setting up redis.

1 Like


I have the latest version of openvas and i have exactly the same issue. I, like sehaj visited all links but nothing really helpful. I really need help please.

Thank you !

I have the same issue.

And I’ve to write the same things again as mentioned in several other threads/topics. You have to look at the corresponding scan report and in this report at the errors tab. Additionally you might take a look at the gvmd.log, openvas.log and ospd-openvas.log files. The location of these files depends on your installation method. Most likely they are somewhere inside the /var/log directory.

1 Like

Got the following error. Not sure how to debug. I did a search on google.
I am getting the error GMP service is down, so took a look at the gvmd.log.
Below is the error I am seeing
md manage: init manage process:sql_open failed openvas

I was able to fix this. Just had to restart my virtual box and it let me in without any problems. Now my error is vts list is empty