Last update ospd-openvas_1 phyton bug

Openvas worked fine for two months. Recent updates cause an error.
I download updates with the script:
docker-compose -f $DOWNLOAD_DIR/docker-compose.yml -p greenbone-community-edition pull

I downloaded the latest OpenVAS container file updates (pull). Unfortunately there is a bug in the python script in the openvas container.
System: Ubuntu 22.04
Instalation manual:

ospd-openvas_1 | Traceback (most recent call last):
ospd-openvas_1 | File “/usr/local/bin/ospd-openvas”, line 8, in
ospd-openvas_1 | sys.exit(main())
ospd-openvas_1 | File “/usr/local/lib/python3.9/dist-packages/ospd_openvas/”, line 1264, in main
ospd-openvas_1 | daemon_main(‘OSPD - openvas’, OSPDopenvas, NotusParser())
ospd-openvas_1 | File “/usr/local/lib/python3.9/dist-packages/ospd/”, line 126, in main
ospd-openvas_1 | daemon = daemon_class(**vars(args))
ospd-openvas_1 | File “/usr/local/lib/python3.9/dist-packages/ospd_openvas/”, line 480, in init
ospd-openvas_1 | self.main_db = MainDB()
ospd-openvas_1 | File “/usr/local/lib/python3.9/dist-packages/ospd_openvas/”, line 615, in init_
ospd-openvas_1 | super().init(self.DEFAULT_INDEX, ctx)
ospd-openvas_1 | File “/usr/local/lib/python3.9/dist-packages/ospd_openvas/”, line 437, in init
ospd-openvas_1 | self.ctx = OpenvasDB.create_context(kbindex)
ospd-openvas_1 | File “/usr/local/lib/python3.9/dist-packages/ospd_openvas/”, line 116, in create_context
ospd-openvas_1 | ctx.keys(“test”)
ospd-openvas_1 | File “/usr/local/lib/python3.9/dist-packages/redis/commands/”, line 1933, in keys
ospd-openvas_1 | return self.execute_command(“KEYS”, pattern, **kwargs)
ospd-openvas_1 | File “/usr/local/lib/python3.9/dist-packages/redis/”, line 1258, in execute_command
ospd-openvas_1 | return conn.retry.call_with_retry(
ospd-openvas_1 | File “/usr/local/lib/python3.9/dist-packages/redis/”, line 46, in call_with_retry
ospd-openvas_1 | return do()
ospd-openvas_1 | File “/usr/local/lib/python3.9/dist-packages/redis/”, line 1259, in
ospd-openvas_1 | lambda: self._send_command_parse_response(
ospd-openvas_1 | File “/usr/local/lib/python3.9/dist-packages/redis/”, line 1234, in _send_command_parse_response
ospd-openvas_1 | conn.send_command(*args)
ospd-openvas_1 | File “/usr/local/lib/python3.9/dist-packages/redis/”, line 916, in send_command
ospd-openvas_1 | self._command_packer.pack(*args),
ospd-openvas_1 | AttributeError: ‘UnixDomainSocketConnection’ object has no attribute ‘_command_packer’
greenbone-community-edition_ospd-openvas_1 exited with code 1

Reported at
Seems to be an issue in a dependency. redis-py release 4.5.0 is broken

I’ll try to update the container image today to fix the issue.

1 Like

I had problems too.

Should be fixed now. Please pull the latest images.


Thank you. Now it works properly !
Remember to download a set of new images to docker.
Reconstructing NVT’s CVE signature database support some time. Watch the logs and wait for the process to complete.


greenbone/pg-gvm - do not change :wink: