Configuration SSH access KEY

Hi, newbie, just installed the VM 5.0.6 of the GCE.
I have been able to make some scans, they work fine.
Now I tried to configure SSH access, so after going in SETTINGS, SSH, SSH ACCESS I try to upload the key I’m generating with puttygen but each time I try to upload a key the system says:

Unable to decode the key.
Make sure that you upload the public part of your authentication key.
The optional comment field must be set to display the key later on.

Now, the key I try to upload is the public key that puttygen generates.
It even has the comment field set and populated.

Tried to use the key passphrase or to leave it blank but it makes no difference.
Tried to download the last version of putty suite (i was on 0.71 downloaded 0.72) but the result is the same.

I’m sure I’m doing something wrong but I cannot find the issue…




I suppose putty generates keys in a different format. The format must correspond to RFC 4716 which is used by OpenSSH.

Some random stack overflow article about that topic

1 Like

Ok, you pointed me in the right direction, thanks.
The documentation didn’t say anything about formats, just to create the key with puttygen or openssh so I didn’t think it could be an issue.
I resolved creating it directly with openssh and importing the private key in Putty because the reverse procedure didn’t work, tried several tutorials without success.

Thanks again.